jQuery 1.9 RC1 and Migrate RC1

1/9/2013 10:03:36 PM By Felipe Pessoto

Menos de um mês após o Beta 1 saiu a versão Release Candidate 1. A nova versão 1.9 é um marco na história do jQuery, a intenção é remover o "lixo" acumulado pra manter a compatibilidade com versões antigas, assim muitas partes que estavam obsoletas foram removidas do código.

Para manter funcionando a base de código atual eles disponibilizaram um plug-in chamado jquery-migrate que permite restaurar as funcionalidades obsoletas, emitindo um alerta no console de desenvolvimento, assim você pode ajustar os códigos conforme for possível.

Na versão seguinte, 2.0, será abandonado o suporte aos Internet Explorer´s 6, 7 e 8 que hoje são um problema, obrigando o time do jQuery a inserir diversos hacks pra funcionar como deveria. Assim a versão 2.0 será menor, mais rapida e com menos problemas causados por esses hacks.

Para fazer a migração é só substituir o seu script jQuery por estes:

<script src="http://code.jquery.com/jquery-1.9.0rc1.js"></script>
<script src="http://code.jquery.com/jquery-migrate-1.0.0rc1.js"></script>

Se você usa o jQuery 1.6.4 ou superior também pode incluir apenas o jquery-migrate para ver quais avisos aparecem.

Ao achar algum bug, você deve reportar no site http://bugs.jquery.com